Webpage link - is it possible to not autocreate a record and use a webpage link?

I am creating a simple request form that I need to make available to non-logged in users. I have been advised to create a webpage (public) with a webpage link to a webpage (authenticated) to make things more secure.

I have found that the weblink won’t work (it is greyed out and hovering over it displays record not available) unless I tick autocreate record in the Basics of the webpage.

I would prefer to avoid this page creating records as I suspect that it will result in an abundance of blank records in the system.

Is there any way of redirecting from a webpage (public) to webpage (authenticated) without creating a record on the first page?

Thanks in advance,

I don’t think so, as an authenticated page must have a context ID.

Your public webpage should have no base object, the form widget should have a base object.

The following auth page should have the same base object as your form widget on the public page, then it should all work

1 Like

Thanks for the quick reply.

That’s how I have it set up - but was just hoping I could avoid the inevitable unnecessary records.

Thanks again,

We often use rules to clean up records that are created unnecessarily (for example where we include a file upload on a page in a widget group with a parent record) we will do a rule that deletes record if the file attribute is empty

Another thought, are you collecting data on page 1? if not, page 2 could be a public webpage too (not sure if i’m understanding your situation).

We’re not collecting data on p1, it’s purely a redirect.

With the public webpage - I can’t get the link to work if there is no base object on the page. It only works with a base object and the auto create record option ticked. That seems to contradict what you thought would work - have I misunderstood?

Again, thanks for the feedback on this.

does this help: https://croydon-place-build.oncreate.app/w/webpage/1042EEACA1

Yes! That is what I was hoping to achieve, but with the second page as authenticated.

Thanks for your help Kevin.