API - 403 Forbidden response

Hi

I am using LibCreate to interface between 2 systems and when I set up an endpoint to test API formats using postman I get a 403 forbidden response.

I have set the API to not use any firewall and authenticating using the API-Authentication: “token”.

API is set to on in settings - so a little stumped…

Hi Simon

If the API Function “type” is set to “Liberty Create”, then the “API-Authentication” should be sent via the HTTP Headers.

If the API Function “type” is set to “Generic”, then the “API-Authentication” must be configured within the “Request Data” tab either as a “HTTP request headers” or “HTTP request variables” (aka Query String Parameter)

HTTP request headers

HTTP request variables

Hope this helps

Regards
Liam

Hi Liam

coming back to this problem as I still get 403 responses even with a create REST endpoint auth in header. I am testing this in postman first before moving it to the Snaplogic pipeline I am integrating with.

I know what I want to do but can’t seem to get it working