Error importing XLSX files

A supplier has updated their system and are now providing xlsx exports rather than CSV. I have re-configured the importer, however getting an error when i try to import. I’ve attached screenshots to show the settings. Does any one have any tips for imported xlsx files?

I’ve tried changing to types allowed “all” and also tried renaming the file

Morning Kevin,

Have you tried it with an xlsx file of your own, or simplifying the filename. I wonder if the parser is tripping over some of the characters in that filename.

If we can establish the issues we can look to get it resolved.
Either way, could you send me a stripped / reduced and/or redacted version I can test with too.


Thanks for you quick reply, I’ve emailed you.

What Create Version are you on?
What Object type is the import associated with?

I have had success with 22.3.


Dates converted automatically to the date and time property type without a field processor.
It also worked when I added the two footer lines.

We are on 2021.3 at the moment
It’s a general object


Raised as bug #25447.
I’ll keep you updated on progress.

1 Like

We are unable to recreate the issue, can you check the file doesn’t have a double extension or whitespace. Try another file and or another browser.

This is from your system:

Thats very strange, i’m still getting the same error on both Chrome and Safari

However, if i download the file you succesfully uploaded - I can upload it, did you edit the file in any way?

No editing at all, can you try with the file you sent me?
Try looking into file properties and see if the mime type is incorrect or has been corrupted.

I’ve tried the one i sent you, and the original I was sent but both are failing - I downloaded the original again and didn’t open it (so it remained unaltered) and still doesn’t work.

Aha, so if i open in excel, save, then try - we get success. It must be an issue with the system creating the extract, and re-saving it in excel fixes it

1 Like