Language settings and German letters

Hello everyone!

We switched the windows display language on our Virtual computer from German to English, but then we ran into problems with printing German letters using the type text node (we tried typing German letters into a Word document). We switched the keyboard settings to German, keeping the display language in English but it still did not work.

Note that we did not have any problems when the display language was in German and the keyboard was set to German.

Do you know if there is a way to have English as the display language on the virtual computer but still be able to print special characters from a specific language? Any ideas on which language settings to change and where?

Best regards,
Rebecca Bylund

Hello Rebecca, if input text to the ‘Type Text’ node is in German language I think it will type in German language. It shouldn’t depend on the language display/type settings on the server.

Please can you share the flow that you are trying to run and I can try and simulate the issue at my end.

Please can you try this

  1. Go to ‘Settings’ or ‘Control Panel’
  2. Click on ‘Time & Language’
  3. Click on ‘Language’ - > by default, previously you will have ‘German’ set as ‘Windows display’ and for ‘Keyboard’
  4. I installed ‘German’ as additional language by clicking on ‘Add a language’ under ‘Preferred languages’
  5. After this I ran the ‘Type text’ to print these characters üößüä and it printed correctly for me.

If I change the keyboard language to English, the german characters üößüä are typed as


Hi again!
Thank you for getting back to me.

I think what you are describing would be the solution because on my laptop I can run a flow that prints German characters when I have English as the Windows display language but in the bottom right corner of the screen I have chosen German with German keyboard. The menu doesn’t look the same on the virtual machine but at least I know it’s possible and I will do some detective work.

Thanks a lot for the help!