Submit button - Independent settings, is this a bug?

Last week we upgrade with Netcall some Application BUILD envs from 2020.1 to 2021.3.

Whilst testing I’ve noticed that functionality with submit buttons that previously worked is now broken.
Has anyone else experienced a change in behaviour after upgrading, potentially to any version post 2020.1?

Authenticated webpage that works with the CH framework has a widget group for all components and the destination setting on the widget group are set to none.

The form has multiple submit buttons, that are hidden on page load. Depending on the form options, one of the submit buttons are displayed. Each submit button has different independent settings with destinations of different authenticated webpages.

Expected behaviour and working in 2020.1. Clicking the submit button saves the form and directs the user to the relevant authenticated webpage.

Observed behaviour in 20201.3. The Page reloads without saving and does not direct the user to another webpage.

Hi Craig,

I know we were looking at a couple of options on this for you, if you had managed to reproduce this on an easy page now please let me know and we can review with the team together.


Hi Annie,
My original issue is resolved. I’m not sure if I had something cached that was breaking the page, but this is now working.

When trying to create an easy page to replicate I observed a similar behaviour but different cause that writes to the detective “Problem with the webpage - Public webpage cannot have Record ID parameter”.

I’d like a better understanding of what causes this, but it can wait until the new year.

1 Like

Sorry annie, I made a mistake this is still not working.

I tested the wrong env.

Ok no problem, I’ll let Stuart know and we can jump back on the phone

I forgot to say that this has been resolved. The root cause was due to a map being hidden.
We have made the map visible and “hidden” it offscreen using CSS.

With hiding the map @CraigBarker_Cumbria are you referring to an image you position off-screen or something else?

On one of our authenticated pages (on 2020.2) that has a submit button that directs to another page, Safari users on Macs keep having the page reload instead of redirect, but there is nothing in the page build I can see that would allow that and no other devices or pages have this issue. I can only presume the browser is changing the behaviour in some way in a particular scenario so wonder if it is related to this.

Not an image. It’s a Google Map widget, but yes we are now positioning it off screen. My understanding is there is a known issue in 2021.3 if a map widget is set as hidden row in the widget settings.
The behaviour you describe is very similar to what we experienced, but I didn’t try to reproduce on Safari (saw it on Chrome)